Welcome to the Institute of Continuing Legal Education     login    cart (0
login | cart (0)  
Help
Recommended Browser

ICLE’s website only supports browsers that use TLS 1.2 protocol for security reasons. ICLE also uses HTML5 to deliver video. Browsers with these capabilities include the following:

  • Internet Explorer 11 or higher (ICLE supports)
  • Edge 13 or higher
  • iOS 7.1 or higher (ICLE supports)
  • Android 4.4.2 or higher (ICLE supports)
  • Firefox 47 or higher
  • Safari 6 or higher
  • Chrome 51 or higher

If you are using an older browser, you may want to consider upgrading to the newest version of Internet Explorer, Edge, or Chrome.

Top